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1 Instalace a zásuvné moduly

1.1 Poºadavky na systém

Díky faktu, ºe je aplikace napsaná v jazyce Java, lze ji spustit na v²ech opera£ních
systémech, které podporují Java VM (Virtual Machine) a je na nich tedy nainstalováno JRE
verze 1.6 a vy²²í.

Pro NetBeans IDE 6.8, jehoº platforma je základem programu Patterns Searching, jsou
uvád¥ny následující minimální a optimální hardwarové poºadavky na opera£ním systému
Ubuntu 9.04:

Minimální poºadavky:

• Procesor: 800MHz Intel Pentium III
nebo podobný

• Opera£ní pam¥´: 512 MB

• Volné místo na disku: 650 MB

Doporu£ené poºadavky:

• Procesor: 2.6 GHz Intel Pentium IV
nebo podobný

• Opera£ní pam¥´: 2 GB

• Volné místo na disku: 850 MB

Pro samotnou aplikaci je v²ak minimální poºadavek na opera£ní pam¥´ roven 2 GB, je-
likoº se aplikace spou²tí s parametrem -Xms1024M, coº nastaví po£áte£ní mnoºství alokované
pam¥ti na 1024 MB.

1.2 Instalace

Instalace se provádí spu²t¥ním souboru ur£eného pro uºivatel·v opera£ní systém. Spusti-
telný soubor se nazývá patternssearching-linux.sh pro opera£ní systém Linux a patternssearching-
windows.exe pro systém Windows. Po spu²t¥ní instalátoru je uºivatel proveden instalací
klasickým wizardem.

1.3 Instalace zásuvných modul·

Po prvním spu²t¥ní aplikace je pro správnou funkci nutné nainstalovat n¥které zásuvné
moduly (plugins), pokud uºivatel nevlastní verzi s jiº p°edinstalovanými moduly. Bez nich
bude sice základní funk£nost neporu²ena, ale n¥které funkce nebudou dostupné, a to export
sou°adnic do jakéhokoliv formátu a samotné vyhledávání vzor·. Tyto dv¥ funkce jsou kv·li
p°ípadné implementaci jejich dal²ích variant zprost°edkovány formou plugin·.

S instalací programu jsou distribuovány dva soubory typu .nbm:

• CorrelationAlgorithm.nbm - umoº¬uje vyhledávání vzor· vyuºívajíce korela£ního koe-
�cientu pro ur£ení podobnosti dvou oblastí obrázku

• CSVExport.nbm - provádí export seznamu sou°adnic do formátu CSV

Tyto soubory je t°eba nainstalovat pomocí NetBeans nástroje Plugins:

1. spus´te aplikaci Patterns Searching
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2. otev°ete okno Hlavní menu -> Tools -> Plugins

3. v záloºce Downloaded klikn¥te na Add Plugins a otev°ete dva nbm soubory zmín¥né
vý²e

4. v okn¥ plugins stiskn¥te Install

Po instalaci modul· je t°eba aplikaci restartovat, aby byly jejich funkce k dispozici.
Stejným postupem je moºné kdykoliv doinstalovat dal²í kompatibilní zásuvné moduly.

2 Základní práce s aplikacemi vyuºívající NB platformu

P°edností aplikací, které vyuºívají platformu NetBeans, je p°edev²ím kompaktní gra�cké
rozhraní s moºností velmi rozsáhlé variability z pohledu uºivatele. Vlastní kon�gurace nástro-
jových li²t (Toolbars) je ve v¥t²in¥ softwar· samoz°ejmostí, co v²ak jiº tak b¥ºné není, je
moºnost vlastního uspo°ádání vnit°ních oken aplikace.

2.1 Nastavení

Nastavení neboli Options je p°ístupné v Hlavní menu -> Tools -> Options. V okn¥ se
nachází jedna záloºka pro aplikaci Patterns Searching (Algorithms), která bude popsána
níºe a defaultní záloºky, z kterých uºivatel nejvíce ocení Keymap, kde je moºné nade�novat
vlastní klávesové zkratky.

2.2 Nástrojové li²ty

Kon�gurace nástrojových li²t je moºná klasickým p°etahováním li²t po nástrojovém
menu, nebo pomocí menu, které je dosaºitelné bu¤ jako Popup Menu kliknutím pravého
tla£ítka na nástrojové menu, nebo jednodu²e p°es Hlavní menu -> View -> Toolbars.

2.3 Okna

Ve²kerá vnit°ní okna aplikace lze zavírat b¥ºným zp·sobem (k°íºkem v pravém horním
rohu) a otvírat pomocí menu Window. Velká výhoda aplikací vyuºívající NB platformu je
moºnost m¥nit uspo°ádání oken pomocí p°etahování, £i vytaºení zano°eného okna mimo
hlavní okno aplikace funkcí Undock Window p°ístupné v Popup Menu daného okna.

Okno se uchopí my²í za svou horní li²tu a táhne se na poºadované místo. P°i pohybu se
na r·zných místech objevují oranºové obrazce, které nazna£ují jak se okno uchytí p°i pu²t¥ní.

Okno, které zobrazuje na£tené obrázky se dá také maximalizovat kliknutím na tla£ítko
v pravém horním rohu tohoto okna.

Okna vyskytující se p°eváºn¥ na okrajích m·ºou existovat ve dvou stavech - minimalizo-
vaný a klasický, jak je znázorn¥no na obrázku 1. Klasický stav je vid¥t na obrázku na okn¥
Output, není na n¥m nic zvlá²tního a dá se minimalizovat pomocí ikony v pravém horním
rohu. Na levé li²t¥ jsou vid¥t dv¥ minimalizovaná okna (Patterns Groups Manager a Pat-

terns Manager). Pokud se na takováto okna najede nebo klikne my²í, do£asn¥ se zviditelní.
Kliknutím na tmavou te£ku v pravém horním rohu (Pin) se okno p°epne do klasického stavu
a je tedy viditelné stále.
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Obrázek 1: Dva stavy oken

3 Pouºívání aplikace Patterns Searching

3.1 Nastavení

Okno nastavení se otev°e v menu Tools -> Options a obsahuje st¥ºejní záloºku Algorithms
obsahující základní nastavení vyhledávání vzor·, jak je vid¥t na obrázku 2.

V pravé £ásti okna se nachází combo box s výb¥rem n¥kolika moºností chování okraj·
obrázku p°i vyhledávání. Zobrazení t¥chto moºností na jednoduchém objektu je vid¥t na
obrázku 3.

Levá £ást okna Options obsahuje nastavení defaultních algoritm· pouºívaných hlavn¥
p°i vyhledávání funkcí Quick Run. Do skupiny algoritm· je moºné p°idat dal²í (pokud jsou
dostupné a pokud jiº v seznamu nejsou) tla£ítky Add nebo Add All, £i odstranit vybrané
tla£ítkem Remove. Jsou k dispozici také tla£ítka pro zm¥nu po°adí algoritm·, a to Move Up

a Move Down. Kaºdý algoritmus má dále své vlastní parametry, které je moºné nastavit ve
spodním panelu.
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Obrázek 2: Nastavení

(a) None (b) Mirror (c) Stretch (d) White (e) Black

Obrázek 3: Chování na okrajích obrázk·

3.2 Práce s obrázky

Obrázek (konkrétn¥ mapa) se otev°e poloºkou Hlavní menu -> File -> Open Image a po
vybrání poºadovaného souboru se zobrazí v okn¥ typu Edtior. Toto okno obsahuje vlastní
panel nástroj· viditelný na obrázku 4. Toolbar obsahuje následující funkce (v po°adí zleva
na zmín¥ném obrázku):

• Add New Pattern - pokud je v otev°eném obrázku vybraná oblast znázor¬ující vzor,
otev°e dialogové okno pro p°idání tohoto vzoru (obrázek 6)

• Selection Tool - umoºní vybírat £ásti obrázku pomocí taºení my²i

• Move - umoºní pohybovat obrázkem taºením my²i
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• Set points for transformation - klikáním pravého tla£ítka my²i se vyplní p°íslu²ná
polí£ka sou°adnic v okn¥ Transformation Window, které je p°ístupné z menu Window

• Zoom In - p°iblíºí obraz

• Zoom Out - oddálí obraz

• No Zoom - nastaví p·vodní velikost obrázku

• Image combo box - obsahuje seznam existujících variant obrázku, které jsou aplikací
podporované (original, threshold, gray) - varianta se zobrazí jejím výb¥rem

• Results combo box - obsahuje výsledky vyhledávání na daném obrázku - výb¥rem
výsledku (název se shoduje s názvem vzoru, který byl hledán) se v obrázku zobrazí
barevné obdélníky znázor¬ující nalezené vzory

Obrázek 4: Panel nástroj· vieweru obrázk·

3.3 Správa vzor·

V této aplikaci se vzory d¥lí do skupin, které z pohledu vyhledávání p°edstavují vlastní
vzory. Tyto skupiny obsahují libovolný po£et obrázk· (v¥t²inou £ástí p·vodní mapy), které
se pro vyhledávání zpr·m¥rují a vytvo°í jeden kombinovaný vzor. P°íklad této struktury je
vid¥t na obrázku 5, kde je první °ada ukázka jednotlivých vzor· z necelých t°iceti vzor·
skupiny a osamocený vzor dole je kombinovaný vzor.

3.3.1 Skupiny vzor·

Skupiny vzor· se editují v okn¥ Patterns Groups Manager, kde je vid¥t jejich seznam
s po£tem jednotlivých vzor· v závorce a je moºné vytvá°et nové skupiny, p°ejmenovávat £i
mazat stávající, a to tla£ítky Add, Rename a Delete umíst¥nými pod seznamem skupin.

Okno je zobrazeno na obrázku 7b.

3.3.2 Vzory

Okno pro spravování jednotlivých vzor· skupin se nazývá Patterns Manager (obrázek
7a). Ve vrchní £ásti je k výb¥ru nabídka skupin, pod níº se nachází seznam vlastních vzor·
s náhledem a check boxem ur£ujícím, zda se má vzor pouºít. Pod seznamem jsou k dispozici
tla£ítka pro manipulaci se vzory. Edit otev°e dialogové okno s názvem Edit Pattern, jehoº
obsah a funkce je shodná s dialogem pro uloºení nového vzoru (obrázek 6). Tla£ítko Delete
smaºe vybraný vzor a poslední tla£ítko Select All za²krtne/od²krtne v²echny vzory. Poslední
komponenta v okn¥ Patterns Manager je náhled kombinovaného vzoru.

P°i vytvá°ení nového vzoru je t°eba drºet se následujícího postupu:
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Obrázek 5: Jednotlivé vzory a kombinovaný vzor

Obrázek 6: Uloºení nového vzoru

1. ozna£it na map¥ oblast znázor¬ující vzor (oblast se dá následn¥ o°íznout ale ne zv¥t²it)

2. kliknout na tla£ítko Add New Pattern v toolbaru vieweru obrázk·

3. v otev°eném dialogu (obrázek 6) vybrat skupinu, pomocí sou°adnic a velikosti ur£it
výsledný vzhled vzoru a p°ípadn¥ p°idat referen£ní bod aktivováním tla£ítka vpravo
dole u náhledu vzoru a kliknutím na poºadované místo ve vzoru

4. potvrdit tla£ítkem OK

3.4 Transformace sou°adnic

Pro kaºdou mapu je moºné nastavit transformaci sou°adnic pomocí bod· ur£ených
ve dvou sou°adnicových soustavách. Tyto body se editují v okn¥ Transformation Window
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(a) Patterns Manager (b) Patterns Groups Manager (c) Transformation Window

Obrázek 7: Okna pro správu vzor· a transformací

(obrázek 7c).

Sou°adnice bod· z obrázku se získávají klikáním pravým tla£ítkem na mapu s aktivovanou
volbou Set points for transformation v panelu nástroj·. Sou°adnice z druhé soustavy se vepí²í
do polí£ek X real a Y real a bod se p°idá do seznamu tla£ítkem Add. Ze seznamu se dají
body odstranit stisknutím tla£ítka Remove.

Sou°adnice se transformují pouze p°i exportu, a to podobnostní transformací.

3.5 Zpracování obrázk· a vyhledávání

Pro spu²t¥ní vyhledávání existují dv¥ moºnosti, a to klasický start, kterým uºivatele
provede wizard se t°emi panely pro nastavení, nebo rychlý start bez jakéhokoliv dialogu. Pro
kterýkoliv druh je doporu£ené (pokud to povaha obrázku dovoluje), provést na obrázku pra-
hování, neboli thresholding (p°evedení obrázku na £ernobílý). Samoz°ejm¥ je pro optimalizaci
vyhledávání poºadováno, aby vzory byly také vytvá°eny z t¥chto prahovaných obrázk·.

3.5.1 Prahování (Thresholding)

Prahování je typ zpracování obrazu, p°i kterém je obrázek p°eveden na £ernobílý pomocí
takzvaného prahu, který rozd¥lí pixely obrazu na dv¥ skupiny - sv¥tlej²í pixely neº je práh
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a ty tmav²í. Barvy t¥chto pixel· se tedy zm¥ní na £ernou a bílou podle jejich p°íslu²nosti k
dané skupin¥, jak to znázor¬uje obrázek 8 s prahem 128.

Obrázek 8: Prahování (práh = 128)

Provést thresholding je moºné dv¥ma zp·soby. První z nich je otev°ením dialogu Thres-

holding z menu Hlavní menu -> Run -> Thresholding. P°íslu²ný dialog je podobný prvnímu
panelu z wizardu Run, který je zobrazen na obrázku 9. T°i radiová tla£ítka ve vrchní £ásti
dialogu ur£ují zp·sob vybírání obrázku, na který se má prahování aplikovat. První dva jsou
v téhle chvíli totoºné a ur£ují obrázek otev°ený programem. T°etí volbou uºivatel m·ºe p°esn¥
speci�kovat vstupní soubory tla£ítky Add a Remove. Ve spodní £ásti se nachází polí£ko pro
ur£ení hodnoty prahu. Proces se spustí tla£ítkem Finish. P°i pouºití funkce Thresholding se
p°epí²í u daných obrázk· jiº vytvo°ené prahované obrázky.

Druhá ze dvou moºností, je pouºití prahování p°ímo p°i spu²t¥ní vyhledávání. Jak je
vid¥t na obrázku 9, ve spodní £ásti lze za²krtnout polí£ko pro prahování a nastavit mu
hodnotu. Pokud se tak u£iní, bude u obrázk· které jiº prahování n¥kdy absolvovaly, pouºita
jiº vytvo°ená prahovaná verze (i p°esto ºe mohla být vytvo°ena s jinou hodnotou prahu).
Pro mapy, které threshold verzi nemají, se vytvo°í se zadaným prahem.

3.5.2 Rychlý start (Quick Run)

Metoda spu²t¥ní zvaná Quick Run provede vyhledávání na otev°eném obrázku s default-
ním nastavením algoritm· (zm¥nit nastavení je moºné v Hlavní menu -> Tools -> Options)
a práv¥ vybranou skupinou vzor· v Patterns Manager.

3.5.3 Vyhledávání (Run)

Pomocí wizardu Run, který se spustí poloºkou Hlavní menu -> Run -> Run, je moºné
nastavit obrázky pro vyhledávání, sled vzor· a algoritm· a jejich nastavení.

První panel wizardu (obr. 9) umoº¬uje speci�kovat obrázky pro vyhledávání a také
pouºití prahování. Tento panel byl popsán v sekci 3.5.1 o prahování.

Následující panel je pro speci�kaci vzor·, které se budou vyhledávat, a jejich po°adí.
Doporu£uje se vyhledávat nejprve v¥t²í vzory a nakonec men²í. Pokud totiº n¥jaký velký
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Obrázek 9: Výb¥r soubor· pro aplikaci vyhledávání

vzor obsahuje také £ást podobnou vzoru malému, tímto postupem se eliminuje moºnost ºe
se bod ozna£ující polohu vzoru uloºí do výsledku dvakrát (pro malý a velký vzor). V pravé
£ásti panelu se nacházejí tla£ítka pro správu seznamu vzor· - p°idání je moºné pomocí Add
(otev°e dialog pro výb¥r vzoru) nebo Add All (p°idá v²echny existující vzory), odebrání
stiskem Remove a pro zm¥nu po°adí jsou Move Up a Move Down.

Obrázek 10: Nastavení vzor· pro vyhledávání

Poslední panel wizardu Run slouºí k nastavení algoritm· pouºívaných pro toto konkrétní
vyhledávání. Je znázorn¥n na obr. 11 a funk£n¥ je shodný s levou £ástí záloºky Algorithms

v Options popsané v sekci 3.1.

3.5.4 Kontrola výsledk· (Check)

Kontrola výsledku pomáhá uºivateli projít mapu s vyhledanými vzory a p°idat £i odebrat
n¥která místa, která vyhledávací algoritmus nerozpoznal správn¥.
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Obrázek 11: Nastavení algoritm· pro vyhledávání

Wizard pro spu²t¥ní kontroly se nachází pod poloºkou Hlavní menu -> Run -> Check

a obsahuje dva panely. První z nich je pro ur£ení konkrétního výsledku ke kontrole a je
zobrazen na obr. 12. Výsledky jsou v aplikaci uchovávány ve form¥ stromu - pro kaºdou mapu
(ur£enou souborem) v²echny její výsledky (ur£ené názvem vzoru). Proto je t°eba vybrat
nejprve soubor a poté vzor ve dvou seznamech ve vrchní £ásti prvního panelu. Pod nimi
je je²t¥ náhled velikosti mapy, která se dá m¥nit scrollováním nebo hodnotou vpravo od
náhledu, ale nedá se jiº zm¥nit jakmile se kontrola spustí.

Obrázek 12: Ur£ení výsledk· pro kontrolu

Ve druhém panelu je pouze nastavení chování kontroly, které je moºné ponechat beze
zm¥ny. První poloºka, jeli za²krtnutá, znamená, ºe se oblasti, které uºivatel ozna£í jako vzory
(algoritmus je nesprávn¥ ozna£il za b¥ºné oblasti), permanentn¥ uloºí na pevný disk a bude
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moºné je p°i p°í²tích vyhledáváních pouºívat. Zde je nutné dodat, ºe více vzor· sice zp°esní
vyhledávání, ale p°íli² mnoho vzor· ur£itou m¥rou sníºí výkon nap°íklad p°i pouºívání Pat-
terns Manageru. Druhá poloºka v tomto panelu ur£uje, o kolik se zv¥t²í vyhledávací okénko
kolem kurzoru my²i oproti kontrolovanému vzoru. Toto okénko je také vid¥t na obrázku 14.

Obrázek 13: Nastavení kontroly výsledk·

Vlastní kontrola probíhá v jednom dialogovém okn¥, pomocí kterého se postupn¥ projde
celá mapa a umoºní opravit chyby vzniklé automatickým vyhledáváním. Ihned po otev°ení
dialogu je moºné zv¥t²it okno tak, jak bude uºivateli vyhovovat. To je sice moºné i po prvním
kroku, ale velikost kroku se jiº nezm¥ní. Jak je vid¥t na obrázku 14, dialogové okno obsahuje
panel nástroj· ve vrchní £ásti, náhled mapy s výsledky a spodní £ást s informací o mnoºství
krok· a tla£ítky pro ukon£ení kontroly.

Postup kontroly je tedy následující:

1. nastavte velikost dialogového okna tak, jak vám to bude vyhovovat (poté to jiº není
vhodné)

2. prohlédn¥te zobrazenou oblast a opravte chyby - v základním módu (v panelu nástroj·
je vybrané tla£ítko s ikonkou plus) se kliknutím levého tla£ítka my²i daná oblast pod
vyhledávacím okénkem prohledá a místo s nejlep²í shodou se p°idá jako vzor a kliknutím
pravého tla£ítka na n¥jaký ozna£ený vzor se tento vzor odstraní; v módu s vybraným
tla£ítkem mínus fungují tla£ítka obrácen¥ a nezobrazuje se vyhledávací okénko

3. p°ejd¥te na dal²í oblast mapy kliknutím prost°edního tla£ítka my²i, nebo stisknutím
tla£ítka v toolbaru se ²ipkou sm¥°ující doprava

4. opakujte kroky 2 a 3 dokud neprojdete celou mapu

5. p°i zvolení dal²ího kroku na poslední oblasti mapy se kontrola ukon£í a zobrazí se dialog
ptající se na uloºení zm¥n

B¥hem kontroly je moºné ji ukon£it bu¤ tla£ítky v pravém spodním rohu, nebo zav°ením
okna, vºdy se ale zobrazí dialog s otázkou, zda si je uºivatel jist a chce-li zm¥n¥né výsledky
uloºit.

3.6 Správa výsledk·

Výsledky jsou uchovávány pro kaºdou mapu a vzor po dobu b¥hu aplikace. Mapy které
jiº n¥jaké výsledky mají se objeví v rolovací nabídce toolbaru Results (obr. 15). Tento panel
nástroj· obsahuje zleva následující funkce:

• Results for �le - výb¥r z existujících výsledk· popsaných názvem souboru (mapy)
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Obrázek 14: Kontrola výsledk·

• Display - otev°e danou mapu v prohlíºe£i obrázk·, kde je moºné zobrazit výsledky pro
ur£itý vzor jak bylo popsáno v kapitole 3.2

• Clear - smaºe ve²keré výsledky pro vybranou mapu

• Transformation - otev°e dialogové okno pro správu identických bod· (obsah okna je
shodný s obsahem Transformation Window popsaném v sekci 3.4)

Obrázek 15: Panel nástroj· pro správu výsledk·

3.6.1 Export sou°adnic

Export sou°adnic je umoºn¥n díky nainstalovaným zásuvným modul·m. Je tedy moºné,
ºe by n¥který modul obsahoval pro export n¥jaká dal²í okna, to v²ak musí být náplní uºiva-
telské p°íru£ky p°íslu²ného modulu. P°i exportování sou°adnic se vºdy objeví okno zobrazené
na obrázku 16. V tomto okn¥ je moºné vybrat jeden £i více soubor· (map) pro export. Modré
poloºky v seznamu mají nastavené identické body pro transformaci a pokud je ve spodní £ásti
za²krtnuto polí£ko Transform coordinates, tato transformace se na sou°adnice aplikuje.

Po ozna£ení exportovaných výsledk· se otev°e dialog Save pro výb¥r souboru, do kterého
se mají sou°adnice uloºit. M·ºe záleºet na konkrétním druhu exportu, ale je b¥ºné, ºe pokud
je vybráno více map, kterým se mají výsledky exportovat, vytvo°í se více soubor· se sou°ad-
nicemi - pro kaºdou mapu jeden, a jejich jména se budou skládat z názvu zadaným uºivatelem
a £ísla, které se automaticky generuje.
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Obrázek 16: Export sou°adnic

3.7 Projekty

Správa projekt· je v aplikace Patterns Searching spí²e provizorní. Projekt lze pouze uloºit
a poté zase na£íst, a to do XML souboru. Konkrétn¥ se ukládá/na£ítá seznam otev°ených
obrázk· a ve²keré výsledky, které aplikace uchovává b¥hem b¥hu.
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